[Wien] Frontend und Map

Markus Kittenberger (spam-protected)
Mo Aug 29 17:31:49 CEST 2011


klingt danach als ob es keine nat rule für den tunnel gibt,..
(und der traffic eben ungenatet am tunnel rausgeht,..)

iptables -t nat -nvL

falls dort interface spezifische nat rules drin stehen (und davon gehe ich
aus *G)
dann fehlt sicher die für das tunnelinterface,..

wie habt ihr denn eure tunnel gebaut?

lg Markus

2011/8/29 Petr Koval <(spam-protected)>

> Das Problem tritt "immer" dann, wenn source ip, eine tunnel ip auf dem
> Router
> also dann wenn gerade eine destination ip über tunnel geroutet wird.
> Wenn aber, obwohl tunnel on, über ein anderen weg, sei es wan oder
> wlan, geroutet wird,
> tritt das Problem nicht zu. Dann ist ja die source ip die des wans,
> resp. wlans und nicht
> die des tunnel devices.
> Ich gehe es um in dem ich mich nicht direkt von tunnelnden Router naten
> lasse,
> sondern zwischen die NAT und den tunnelnden Router noch einen zwischen
> olsr Router
> schalte. Dann verschiebe ich mich von der tunnelnden ip als source ip
> auf eine weitere,
> von der dann das Problem nicht mehr auftritt.
>
> lgp
>
> Am 29.08.11 schrieb Christian Bruckner <(spam-protected)>:
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> >
> > Gregor Glashüttner schrieb:
> >> Am 28.08.2011 19:53, schrieb Christian Bruckner:
> >>> Hallo Funker,
> >>>
> >>> Wieso komme ich nicht auf
> >>>
> >>> https://marvin.funkfeuer.at/frontend_wien/index.php und
> >>> https://map.funkfeuer.at/wien/?
> >>>
> >>> wenn ich direkt am Tunnel-Device hänge?
> >>
> >> Du meinst wenn du´s direkt vom Tunnel-Device aus probierst? Oder
> >> dich direkt dranhängst? Bei mir daheim geht´s jedenfalls auch
> >> direkt am Tunnel...
> >
> > ja so ist es, zum frontent komme ich per Browser aber der Login
> > funktioniert nicht und zu Map komme ich gar nicht, sollte aber per
> > tracerout und ping ersichtlich sein
> >
> >>
> >>> Liegt das Problem in meiner Config??
> >>
> >> Dazu wär´s gut deine Config zu kennen! ;-) Bzw. auch dein
> >> physisches Setup. Hängt dein 0xff-Router der den Tunnel aufbaut mit
> >> dem LAN am Internetrouter? So sieh´s nämlich laut deinen
> >> Routingeinträgen aus:
> >
> > Fast, es hängt noch zwischen Provider- und 0xff-Router noch ein
> > Router. Sonst richtig erkannt. Das heißt ich NATe zweimal bevor ich
> > ins Internet gehe.
> >
> >> static_route=78.41.115.228:255.255.255.255:10.76.56.254:1:br0 führt
> >> zu 78.41.115.228      via 10.76.56.254 dev br0 metric 1
> >
> > Ja
> >
> > Kann es sein, dass mit dem NATen ein Problem gibt?
> >
> > schaut für mich OK aus, Im Tunnel sollte das alles aber eh nicht
> > sichtbar sein.
> >
> >>
> >> Bin mir aber nicht sicher ob das das Problem ist...
> >>
> >> LG Gregor
> >>
> >
> > -----BEGIN PGP SIGNATURE-----
> > Version: GnuPG v2.0.16 (GNU/Linux)
> > Comment: Gnu Privacy Tools
> > Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> >
> > iQEcBAEBAgAGBQJOW1tFAAoJEK0Xbt/HuNNN6awIAKPU/6LEjqR+2KgYd+4kizDK
> > LJIRsXZMjF1P2qdbgA9VwzhQNFs7kfGCGL8Helu5DUjathm9zigd/B2wnrBF8fUr
> > 8ozIDn9qceoG0aeQSyFcTaWu5HAlkX+h2J8hOJhtU/bFMW3xe+QlggeUWaz42FHU
> > nBdx9qYM/HyE3rTm77tTnB5BB1few/TyTNjIYgimqHQTbwZBwe7E9V5EPBRjdM1P
> > MdkvRDtqG7b3x9HgHJMgCHNfWfNePgaZf8gPhf2v5Wzn1sJyoYUyJJJwLQDvxFVB
> > f4WwEQQLv/tYOJUl4hgZ8N/Gfw7lTFfqlnZntqYanLu6Dmt4Rxif6kl1iRrG/3M=
> > =tGO0
> > -----END PGP SIGNATURE-----
> >
> > --
> > Wien mailing list
> > (spam-protected)
> > https://lists.funkfeuer.at/mailman/listinfo/wien
> >
>
> --
> Wien mailing list
> (spam-protected)
> https://lists.funkfeuer.at/mailman/listinfo/wien
>
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.funkfeuer.at/pipermail/wien/attachments/20110829/9ddd228a/attachment.html>


Mehr Informationen über die Mailingliste Wien