[Discuss] Tunnel, was mach ich falsch?

Walter Ring (spam-protected)
Mi Mai 10 23:47:16 CEST 2006


Hab bis jetzt einen Tunnel mit der alten Funkfeuer-Firmware betrieben, hat
reibungslos funktioniert.

 

Hab jetzt Freifunk 1.2.5 draufgespielt und versuch den Tunnel
wiederaufzusetzen, leider ohne Erfolg. Was mach ich falsch?

 

Hier ist mein Tunnel Script:

 

(spam-protected):~# route add 193.239.188.20 via 10.0.0.1

+ exec ip route add 193.239.188.20 via 10.0.0.1

(spam-protected):~# openvpn --mktun --dev tap0

Wed May 10 23:43:21 2006 TUN/TAP device tap0 opened

Wed May 10 23:43:21 2006 Persist state set to: ON

(spam-protected):~# openvpn --dev tap0 --remote 193.239.188.20 --port 5009
--daemon --writepid /var/run/openvpn-tap0.pid --cd /var

(spam-protected):~# ip addr add 193.238.156.58/22 broadcast + dev tap0

(spam-protected):~# ip route del 193.238.156.0/22

(spam-protected):~# ip link set tap0 up

 

ifconfig schaut dann so aus:

 

(spam-protected):~# ifconfig

+ exec ip addr

1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

2: eth0: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc pfifo_fast qlen
1000

    link/ether 00:14:bf:42:53:86 brd ff:ff:ff:ff:ff:ff

3: eth1: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc prio qlen 1000

    link/ether 00:14:bf:42:53:88 brd ff:ff:ff:ff:ff:ff

    inet 193.238.156.18/22 brd 193.238.159.255 scope global eth1

4: br0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue

    link/ether 00:14:bf:42:53:86 brd ff:ff:ff:ff:ff:ff

    inet 192.168.1.1/24 brd 192.168.1.255 scope global br0

5: vlan0: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc noqueue

    link/ether 00:14:bf:42:53:86 brd ff:ff:ff:ff:ff:ff

6: vlan1: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc noqueue

    link/ether 00:14:bf:42:53:86 brd ff:ff:ff:ff:ff:ff

    inet 10.0.0.102/16 scope global vlan1

7: tap0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 100

    link/ether 00:ff:4e:30:99:dc brd ff:ff:ff:ff:ff:ff

    inet 193.238.156.58/22 brd 193.238.159.255 scope global tap0

 

und hier ein ip route:

 

(spam-protected):~# ip route

193.238.156.212 via 193.238.156.14 dev eth1  metric 2

193.238.156.14 dev eth1  scope link  metric 1

193.239.188.20 via 10.0.0.1 dev vlan1

193.238.156.13 via 193.238.156.14 dev eth1  metric 2

193.238.156.136 via 193.238.156.14 dev eth1  metric 1

192.168.1.0/24 dev br0  proto kernel  scope link  src 192.168.1.1

193.238.156.0/22 dev tap0  proto kernel  scope link  src 193.238.156.58

10.0.0.0/16 dev vlan1  proto kernel  scope link  src 10.0.0.102

default via 10.0.0.1 dev vlan1

 

Wie krieg ich jetzt eigentlich den olsrd dazu, auch auf tap0 zu lauschen?
Restarten hab ich versucht.

 

lg walter

 

-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.funkfeuer.at/pipermail/discuss/attachments/20060510/da13aeb6/attachment.html>


Mehr Informationen über die Mailingliste Discuss