<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<div class="moz-cite-prefix">Correct, that's because we were
discussing the possibility of implementing the following changes
in NetworkRoutes:<br>
<ul>
<li>rename "destination" to "destination_address"</li>
<li>add "destination_id"</li>
<li>rename "next" to "next_address"</li>
<li>add "next_id"<br>
</li>
</ul>
And in "NetworkGraph":<br>
<ul>
<li>rename "source" to "source_address"</li>
<li>add "source_id"</li>
<li>rename "target" to "target_address"</li>
<li>add "target_id"</li>
</ul>
<p>Question:<br>
</p>
<ul>
<li>Are you (plural you) sure of wanting to add more attributes?<br>
</li>
</ul>
<p>if yes:<br>
</p>
<ul>
<li>Should the new attributes be mandatory or optional?</li>
<li>Can we avoid the renaming by keeping the attribute name
without the "_address" suffix? We can write in the spec that
those attributes without the suffix refer to addresses by
default, while the ones with "_id" suffix refer to the
"router_id"</li>
</ul>
<p>Federico<br>
</p>
<br>
On 08/11/2015 02:21 PM, Henning Rogge wrote:<br>
</div>
<blockquote
cite="mid:CAGnRvupmqLCa8t=mXwtbKpoPRedUMuJY0umi6-JYKZ=5hzspVA@mail.gmail.com"
type="cite">
<pre wrap="">yes.
I just noticed your list of "ids" were not complete.
Henning
On Tue, Aug 11, 2015 at 1:54 PM, Nemesis <a class="moz-txt-link-rfc2396E" href="mailto:nemesis@ninux.org"><nemesis@ninux.org></a> wrote:
</pre>
<blockquote type="cite">
<pre wrap="">On 08/11/2015 01:34 PM, Henning Rogge wrote:
</pre>
<blockquote type="cite">
<pre wrap="">On Tue, Aug 11, 2015 at 1:30 PM, Nemesis <a class="moz-txt-link-rfc2396E" href="mailto:nemesis@ninux.org"><nemesis@ninux.org></a> wrote:
</pre>
<blockquote type="cite">
<pre wrap="">which attributes do refer to IDs in NetworkGraph and NetworkRoutes
In NetworkRoutes:
router_id
</pre>
</blockquote>
<pre wrap="">maybe a "next_hop_id" would also be good.
This would declare which router/node is used as the next hop of this route.
We (of course) also need the address. So this would be another case of
"split up into id/address".
</pre>
</blockquote>
<pre wrap="">
I guess you are talking about this:
<a class="moz-txt-link-freetext" href="https://github.com/interop-dev/netjson/issues/9">https://github.com/interop-dev/netjson/issues/9</a>
Correct?
_______________________________________________
Interop-dev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Interop-dev@lists.funkfeuer.at">Interop-dev@lists.funkfeuer.at</a>
<a class="moz-txt-link-freetext" href="https://lists.funkfeuer.at/mailman/listinfo/interop-dev">https://lists.funkfeuer.at/mailman/listinfo/interop-dev</a>
</pre>
</blockquote>
</blockquote>
<br>
</body>
</html>